Download
           


Baselight Editions v5 - Academic

Note: This is the academic version of Baselight Editions, which is available to institutions that meet our eligibility criteria. Transactions must be completed with a valid Purchase Order from the institution, which will be requested during the purchasing process. If you have any questions, contact [email protected].

For details on the two academic pricing options—outright licence and annual license subscription—see Education.

To download a 30-day trial version, click here:
Trial Version

The Baselight Editions range not only adds superb colour correction to your shots using a comprehensive set of the powerful features available on full Baselight systems, it also provides fast and efficient workflows for editing and VFX that save you time and money.

Baselight Editions v5 is now available for Avid and NUKE.

Don’t forget, there is also the freelancer option for node-locked licences, which allows you to activate a licence for a limited duration, making it simple to move the licence to a new system when a job finishes.

See the Store FAQs for more information on all of these options.

One purchase also gives you both NUKE and Avid Editions* so that you can pass grades through your pipeline with ease.

Baselight Editions are currently available for the following packages with more to be added soon:

* Each of the Baselight Editions products must be installed on the same system to make use of the single licence.

System Requirements

Floating Licence Server

If you are using Baselight Editions with a floating licence server, you must also have one of the following:

  • Mac server running Mac OS X 10.9 or later, or
  • Linux server running RHEL/CentOS 5 or later

The server installation packages can be downloaded here.

Baselight for NUKE

To use Baselight for NUKE, you must be using:

  • CentOS 7.4 (64-bit) onwards
  • Windows 10 (64-bit) onwards
  • macOS 12 onwards

Supports all current major releases of NUKE 12 and 13, so 12.0, 12.1, 12.2, 13.0 and 13.1.

Baselight for Avid

To use Baselight for Avid, you must be using:

  • macOS 12 onwards
  • Windows 10 onwards
  • Supports the latest Media Composer releases here.

Purchase & download from our online store
Baselight Editions v5 (Academic)
Buy, Try or Call Now
sitemap | accessibility | [email protected]
© 2024 FilmLight Ltd. All rights reserved | Legal notice | RSS Feed